Author Topic: cannot use auxiliary relay on Fedora Core 9  (Read 2542 times)

tcl

  • Guest
cannot use auxiliary relay on Fedora Core 9
« on: November 05, 2010, 03:56:53 »
I am trying to use the Watchdog board Aux Relay to remotely reset one PC (call it S) from a second PC (call it M).

I have a cable running from the Aux Relay to S's reset header

From a Third machine (call it W) running windows I am able to manipulate the Aux Relay and observe S reboot (so the connection is working)

M is running Fedora Core 9 (2.6.27.25-78.2.56.fc9.i686)

When I connect my Watchdog card to M using USB I see that the OS has recognized it. I run dmesg and see:
   usb 2-2: USB disconnect, address 2
   usb 2-2: new full speed USB device using uhci_hcd and address 3
   usb 2-2: configuration #1 chosen from 1 choice
   pcwd_usb: This driver only supports 1 device
   usb 2-2: New USB device found, idVendor=0c98, idProduct=1140
   usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
   usb 2-2: Product: BPI - USB PC Watchdog
   usb 2-2: Manufacturer: BerkshireProducts, Inc.


However when I send the serial port commands described in the "Serial PC Watchdog Command Addendum" I do not observe any reboot. I have tried using the /dev/ttyS0, /dev/ttyS1, /dev/ttyS2, /dev/ttyS3, and /dev/watchdog devices. Is this feature still supported on Linux, an if so how should I discover what device the watchdog board is connected to?

Admin

  • Administrator
  • Jr. Member
  • *****
  • Posts: 49
    • View Profile
Re: cannot use auxiliary relay on Fedora Core 9
« Reply #1 on: November 08, 2010, 16:19:23 »
Hi tcl,
That addendum you found on the CD only applies to the Internal Serial PC Watchdog and External Serial PC Watchdog - it does not apply to the USB version.

We made a lot of updates to the Serial versions about a year ago. New commands were added and a faster baud rate was implemented. These were changes were made to support the new Universal DLL for Windows.